Быстрая помощь бухгалтеру 1С

Информационные (регистрационные) карты сотрудников 1С:Розница

Generic placeholder image

Конфигурация: 1С:Розница

Версия конфигурации: 2.2.2.14

Дата публикации: 09.09.2016

Просмотров: 13753

Если в вашем магазине включена 1С:Розница 2.2 и в РМК работают разные продавцы, удобно будет завести каждому продавцу информационную карту, что бы оценить эффективность работы продавца. Можно создать каждому продавцу отдельный Логин и Пароль на вход, то тогда придется все время закрывать 1С и заново авторизироваться. Что бы избежать этого в программе есть возможность создания Информационной карты сотрудника.

Этот способ удобен, если у вас есть Кассир, а менеджеры в торговом зале консультируют клиентов и потом со своими картами пробивают клиенту на кассе. Очень удобно оценивать эффективность работы менеджеров в торговом зале.

 

Информационные карты это общий справочник, который включает в себя:

1. Дисконтные карты клиентов.

2. Регистрационные карты сотрудников.

 

Отличия Регистрационной карты и Дисконтной, Регистрационная карта не имеет:

1. Вида дисконтной карты

2. Бонусной программы

3. Дополнительной карты для начисления бонусов.

Перейдем к созданию карты сотрудника, переходи в раздел Персонал - Регистрационные карты.

Информационная карта

Создаем новую карту сотруднику.

Информационная карта 1С

Владельцем может быть пользователь информационной базы или физическое лицо, поскольку мы не будет создавать дополнительной авторизации пользователя, то выбираем Физическое лицо. Вводим Код карты (магнитный) или Штрих Код, в зависимости от того что вы используете.

Регистрационная ката 1С

Создаем новое физическое лицо.

Физическое лицо 1С

Заполняем данные сотрудника и выбираем флаг Является сотрудником и выбираем Магазин в котором он работает.

Сотрудник 1С Розница

Сохраняем записываем все документы и переходим в РМК, проверить карту. Вводим Штрих код или Проводим магнитной лентой. 

РМК Регистрационная карта

При дальнейших продажах будет выведен продавец. 

Продавец в 1С:Розница 2.2

Теперь можно посмотреть отчет по продавцу и продажам.

Отчет по продавцу 1С

Заходи в общий отчет продажи.

отчет продажи 1С

Выбираем флаг Продавец и выбираем нашего продавца.

Отчет по продавцам 1С Розница

Если у вас несколько Кассиров удобнее использовать метод с авторизацией пользователя. О нем расскажем в следующей статье.

Комментарии ()

  1. Сергей 22 января 2017, 18:14 # 0
    Все настроено, но не работает. Пишет «Данные по коду не найдены».
    Чего-то не хватает…
    1. Администратор сайта 22 января 2017, 19:39 # 0
      Проверьте (3 рисунок) Код карты и Штрих код разные веши, если вы пытаетесь пробить ее через Штрихкод, а там не заполнено, то ничего не выйдет.
      1. Сергей 22 января 2017, 20:40(Комментарий был изменён) # 0
        Все верно настроено. Физ.лицо — является сотрудником магазина. Есть регистрационная карта (привязана к сотруднику — физ.лицу) со штрихкодом EAN13. При сканировании в РМК пишет — «Данные по коду не найдены»
        1. Администратор сайта 23 января 2017, 04:08(Комментарий был изменён) # 0
          Проверьте, не пересекаются ли ваши штрих коды с кодами весовых товаров, штучных товаров и прочего. В разделе Администрирование — Настройки номенклатуры — Штрихкодирование. Зачастую при изготовлении карт они как раз делают диапазон весового товара, встречал уже такое несколько раз.
          В программе по стандарту заложено:
          21sssssxxxxxz — штучные товары
          22sssssxxxxxz — весовые товары
          23sssssxxxxxz — штучные фасованные
      2. Виктор 21 февраля 2017, 05:13(Комментарий был изменён) # 0
        Все замечательно работает, но можно ли как то зафиксировать последнего продавца? Т.е. продавцы иногда работают по одному и сканировать постоянно карту начнут бубнить и возмущаться, а если не выбирать то на чеке печатается пользователь под которым вошли в базу (Кассир). Авторизация кассира ОС.
        1. Администратор сайта 21 февраля 2017, 08:11 # 0
          Для такой реализации, каждому пользователю ИБ придется сделать настройки. То есть 3 кассира 3 пользователя базы данных, каждому пользователю назначается Администрирование — Персональные настройки пользователей — Настройки пользователя. Добавляете новую настройку «Продавец» и выбираете кто из Продавцов будет по стандарту привязан к этому пользователю. Информационные карты привязываете к Сотруднику.
          1. ХХХ 06 октября 2018, 12:00 # 0
            Для этого добавьте следующий код в модуль формы обработки РМКУправляемыйРежим.

            &Вместо("СоздатьНовыйНабор")
            &НаСервере
            Процедура Расш1_СоздатьНовыйНабор(ОчиститьДокументОбработки = Истина, ОчисткаАвтосохраненныхДанных = Истина)
            	
            	ЕстьТоварыВДокументеРасчета = Ложь;
            	Дата = ТекущаяДатаСеанса();
            	Объект.Дата = Дата;
            	
            	Объект.ВидОперации       = Перечисления.ВидыОперацийЧекККМ.Продажа;
            	//Нариман подставновка продавца по умолчанию
            	Если НЕ Объект.Продавец = ПродавецПоУмолчанию Тогда 
            		//ИЛИ ПродавецПоУмолчанию = Справочники.ФизическиеЛица.ПустаяСсылка() Тогда
            		//Объект.Продавец = Справочники.ФизическиеЛица.ПустаяСсылка();
            		Объект.Продавец = ПродавецПоУмолчанию;
            	КонецЕсли;
            	//Нариман
            	
            	Объект.ЧекККМПродажа           = Документы.ЧекККМ.ПустаяСсылка();
            	Объект.ДисконтнаяКарта         = Справочники.ИнформационныеКарты.ПустаяСсылка();
            	Объект.ВладелецДисконтнойКарты = Справочники.ФизическиеЛица.ПустаяСсылка();
            	Объект.АналитикаХозяйственнойОперации = Справочники.АналитикаХозяйственныхОпераций.РеализацияТоваров;
            	Объект.ПродажаПоЗаказу         = Ложь;
            	Объект.ЗаказПокупателя         = Документы.ЗаказПокупателя.ПустаяСсылка();
            	Объект.Ответственный           = Пользователи.ТекущийПользователь();
            	Объект.Контрагент              = Справочники.Контрагенты.ПустаяСсылка();
            	Объект.ОперацияСДенежнымиСредствами = Ложь;
            	Объект.ДокументРасчета         = Неопределено;
            	
            	Если ТипЗнч(НаборПравИНастроек) = Тип("Структура") И НаборПравИНастроек.Свойство("ор_СкладСборкиЗаказов") Тогда
            		// Если настройками РМК склад не задан, получаем значение по умолчанию для пользователя
            		НаборПравИНастроек.Вставить("ор_СкладСборкиЗаказов",ЗначениеНастроекПовтИсп.ПолучитьСкладПродажиПоУмолчанию(Объект.Магазин,,НаборПравИНастроек.ор_СкладСборкиЗаказов, Объект.Ответственный));
            	КонецЕсли;
            	
            	ЭтоЗачетАванса = Ложь;
            	ЭтоОплатаРассрочки = Ложь;
            	ЭтоВозвратАванса   = Ложь;
            	
            	НомерЗаказа = "";
            	
            	ОчиститьТабличныеЧасти(Объект);
            	
            	Объект.Ссылка        = Документы.ЧекККМ.ПустаяСсылка();
            	
            	ПараметрыУказанияСерий = Новый ФиксированнаяСтруктура(Документы.ЧекККМ.ПараметрыУказанияСерий(Объект));
            	
            	Если ОчиститьДокументОбработки Тогда
            		ЧекККМВОбработке = Неопределено;
            	КонецЕсли;
            	
            	ИдентификаторФормыПредварительныхДанных = Новый УникальныйИдентификатор;
            	НомерОперацииЛогирования = 0;
            	
            	// + Бонусный сервис
            	ОтменитьОплатуБонусами();
            	ЭтотОбъект["ор_ПараметрыКартыПрограммыЛояльности"] = Неопределено;
            	Объект.ор_НомерВнешнейКарты = "";
            	Объект.ор_НомерКартыДляПользователя = "";
            	Объект.ор_ВидВнешнейПрограммыЛояльности = ПредопределенноеЗначение("Перечисление.ор_ВидыБонусныхПрограммЛояльности.ПустаяСсылка");
            	Объект.ор_СписаноБаллов = 0;
            	Объект.ор_НачисленоБаллов = 0;
            	Объект.ор_НомерТранзакции = "";
            	// - Бонусный сервис
            	
            	// + Диапазон карт
            	НомерКартыДляАнализаДиапазона = "";
            	ТипКартыДляАнализаДиапазона   = "";
            	НайденаКартаПоДиапазону       = Ложь;
            	// - Диапазон карт
            	
            	Если ОчисткаАвтосохраненныхДанных Тогда
            		ОчиститьАвтосохраненныеДанные();
            	КонецЕсли;
            	
            КонецПроцедуры
            
            1. Администратор сайта 06 октября 2018, 17:22 # 0
              что вы пишите?
              У вас Расширение конфигурации вы заменяете стандартную процедуру &Вместо(«СоздатьНовыйНабор») на свою Процедура Расш1_СоздатьНовыйНабор, а что бы создать расширение надо зайти в Конфигуратор, Конфигурация — Расширение конфигурации и создать свое, потом добавить Модуль нужный в расширение и вызвать &Вместо… При этом надо иметь ПРОФ версию программы, что бы работать с расширениями. Так что ваш вариант 1. не всем подходит. 2. вы не полностью описали, решение.
          Вы можете авторизоваться на сайте через:
          YandexGoogleVkontakte
          Остались вопросы?

          Задайте нам свои вопросы!

          Задать вопрос!
          Случайная статья:
          Установка цен номенклатуры 1С:Бухгалтерия 8.3

          Установка цен номенклатуры документом или из карточки товара в 1С:Бухгалтерия 8.3

          Читать...